dropdown-list-with-bulk-edit-follow-up-question

Questionsdropdown-list-with-bulk-edit-follow-up-question
Peter Broekman asked 3 weeks ago

Abu, On bulk-edit I have a dropdown that gets two lines extra: 1) empty row and 2) – empty –  next to Yes and No I like to. I set the editrules to required. I think I like the first empty space. If you add submit too fast it will just let everything the same. I also like that if you do not change other fields they stay the same as wqell even if you change one field. I do NOT  like the – empty – it will populate my records with null value which I do not allow, but is somehow allowed (recaorsd are updated to null). Kind regards   Peter Broekman

3 Answers
Abu Ghufran Staff answered 3 weeks ago

Hello,

The -Empty- options comes when you have allowed blank selection in dropdown. See :; options in list.

$col[“editoptions”] = array(“value”=>”:;100:One Hundred;200:Two Hundred;300:Three Hundred”);

If you remove that blank option,

$col[“editoptions”] = array(“value”=>”100:One Hundred;200:Two Hundred;300:Three Hundred”);

then there will be no -Empty- in bulk edit as well.

_________________________
Abu Ghufran - Dev Team
PHP Grid Framework
 
Peter Broekman answered 3 weeks ago

This are my editoptions – so apparently this does not work as expected? In the normal edit I do not have this problem

$colb[“editoptions”] = array(“value”=>”Yes:Yes;No:No”);

Abu Ghufran Staff answered 3 weeks ago

Can you confirm this issue on demos/editing/bulkedit.php demo? The above code is from this demo.

Please share complete column configuration so i can regenerate it.

_________________________
Abu Ghufran - Dev Team
PHP Grid Framework
 
Your Answer

8 + 13 =

Login with your Social Id:

OR, enter

Attach code here and paste link in question.
Attach screenshot here and paste link in question.



How useful was this discussion?

Click on a star to rate it!

Average rating / 5. Vote count:

We are sorry that this post was not useful for you!

Let us improve this post!