PHPgrid does not work with Bootstrap 4.2.1

QuestionsPHPgrid does not work with Bootstrap 4.2.1
David Sims asked 3 months ago

This example works (Bootstrap 4 beta)

https://gist.github.com/gridphp/b622a11579eb8ee4e6c189f35d781cc4

Update¬† components to Bootstrap 4.2.1 the grid just says “loading” and there are errors on console

jquery-migrate-3.0.1.min.js:31 JQMIGRATE: jQuery 3.0.0+ REQUIRED
jquery-migrate-3.0.1.min.js:33 JQMIGRATE: Migrate is installed, version 3.0.1
jquery-migrate-3.0.1.min.js:26 Uncaught TypeError: Cannot read property ‘apply’ of undefined
at Function.e.(anonymous function) [as unique] (https://code.jquery.com/jquery-migrate-3.0.1.min.js:26:28)
at e.fn.init.find (jquery.min.js:2)
at e.fn.init.n.fn.init (jquery.min.js:2)
at new e.fn.init (jquery-migrate-3.0.1.min.js:43)
at n (jquery.min.js:2)
at HTMLTableElement.Q.updatepager (jquery.jqGrid.min.js:9)
at b (jquery.jqGrid.min.js:9)
at Object.success (jquery.jqGrid.min.js:9)
at j (jquery.min.js:2)
at Object.fireWith [as resolveWith] (jquery.min.js:2)
e.(anonymous function) @ jquery-migrate-3.0.1.min.js:26
find @ jquery.min.js:2
n.fn.init @ jquery.min.js:2
e.fn.init @ jquery-migrate-3.0.1.min.js:43
n @ jquery.min.js:2
Q.updatepager @ jquery.jqGrid.min.js:9
b @ jquery.jqGrid.min.js:9
success @ jquery.jqGrid.min.js:9
j @ jquery.min.js:2
fireWith @ jquery.min.js:2
x @ jquery.min.js:4
b @ jquery.min.js:4
XMLHttpRequest.send (async)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
e.ajax @ jquery-migrate-3.0.1.min.js:80
y @ jquery.jqGrid.min.js:9
(anonymous) @ jquery.jqGrid.min.js:9
each @ jquery.min.js:2
each @ jquery.min.js:2
$.fn.jqGrid @ jquery.jqGrid.min.js:9
(anonymous) @ mediabs4.php:129
j @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
K @ jquery.min.js:2
content.js:5 ——–init———– https://www.theseacpages.co.uk/mediabs4.php
jquery-migrate-3.0.1.min.js:140 Uncaught TypeError: e.event.addProp is not a function
at Object.e.event.fix (jquery-migrate-3.0.1.min.js:140)
at HTMLTableElement.dispatch (jquery.min.js:3)
at HTMLTableElement.r.handle (jquery.min.js:3)
e.event.fix @ jquery-migrate-3.0.1.min.js:140
dispatch @ jquery.min.js:3
r.handle @ jquery.min.js:3

 

Updating Jquery to 3.3.1 and it works again:

https://www.theseacpages.co.uk/mediabs4.php

 

 

 

1 Answers
Abu Ghufran Staff answered 2 months ago
_________________________
Abu Ghufran - Dev Team
PHP Grid Framework
 
Your Answer

10 + 3 =

OR, enter

Attach code here and paste link in question.
Attach screenshot here and paste link in question.



How useful was this discussion?

Click on a star to rate it!

Average rating / 5. Vote count:

As you found this post useful...

Follow us on social media!

We are sorry that this post was not useful for you!

Let us improve this post!