Selecting – Empty – within Bulk Edit on integer fields causes SQL error

QuestionsSelecting – Empty – within Bulk Edit on integer fields causes SQL error
Richard Samson asked 2 weeks ago

I have a select (drop down) field configured where users select a name and the respective employee id is written to the mySQL database field.  The database field is set an integer data type.

During normal record editing if I set that field blank the database entry write a Null.

However, if I select ” – Empty – ” during bulk editing it’ll try and set those fields to “” instead of Null, resulting in a incorrect integer SQL error.

Is there a way to ensure the ” – Empty – ” option writes Null values instead of “” for this column?  I’ve tried the isnull column parameter but that doesn’t appear to make a difference.

Thanks.

 

 

2 Answers
Abu Ghufran Staff answered 2 weeks ago

Hi,

I’ve emailed you latest build. It should make ‘isnull’ property work as expected.

_________________________
Abu Ghufran - Dev Team
PHP Grid Framework
 
Richard Samson answered 1 week ago

I’ve just tested with the updated version and it now works superbly.  Many thanks for your excellent support.

Your Answer

6 + 14 =

Login with your Social Id:

OR, enter

Attach code here and paste link in question.
Attach screenshot here and paste link in question.



How useful was this discussion?

Click on a star to rate it!

Average rating / 5. Vote count:

We are sorry that this post was not useful for you!

Let us improve this post!